Error 3140: There is an invalid reference to QuickBooks Item "" in the Invoice line.

Understand and resolve cases when seeing Error 3140 in MyWorks Sync > Log. This can be caused by a product in the order not being mapped, or no default product set in MyWorks Settings.

Written by the MyWorks Team

Updated at June 30th, 2023

Table of Contents

Keep getting this error when pushing orders to QuickBooks Desktop using MyWorks Sync?

Error

Error Number:3140

Error:There is an invalid reference to QuickBooks Item "" in the Invoice line.

Causes

  1. A default unmatched product, shipping, or coupon setting is not set in MyWorks Sync > Settings > Defaults.
  2. A product in the WooCommerce order is not mapped in MyWorks Sync > Map > Products.
  3. A QuickBooks product for a custom fee line item is not yet set at MyWorks Sync > Compatibility > WooCommerce Order Fee Line Items (if a custom fee line item is being used in the corresponding order)

Resolution

Ensure that all Default Settings are set.

  1. Visit MyWorks Sync > Settings > Defaults.
  2. Make sure that all dropdowns in this tab are correctly set, and not left blank.

Ensure that your products are mapped.

  1. Visit MyWorks Sync > Map > Products.
  2. Make sure all products that are in both WooCommerce and QuickBooks are correctly mapped here. If a product in the correspondingWooCommerce order is not mapped on this page, it can either be pushed to QuickBooks - or - if the "Default for Unmatched Products" setting is set above in MyWorks Sync > Settings > Defaults, the mapping can be left blank if it's not desired to map it to a specific QuickBooks product.

Ensure that a product for the fee line item is set.

  1. Visit MyWorks Sync > Compatibility.
  2. Make sure that there is a QuickBooks product set for the fee line item if the WooCommerce Order Fee Line Items is enabled, and not left blank.